ManageEngine Forums
I have enabled POP based mail retrieval on sdp latest version and upon saving it says:
FAILURE :Email Settings saved successfully. Could not find valid certification path to requested target,so kindly configure to apply Trusted/Self Signed Certificate
The mail server is a linux one where pop is provided by dovecot

Replies (3)

Restart the Servicedesk Service once.  Stop the Mail fetching under Admin-->Mail sever settings. If you have configured POP for the Mailbox, select the protocol POP while configuring the Mail Server settings under Admin tab. 

Refer to the troubleshooting Document:

Priya K

I have the same problem even when I restart the service it didn't pick up any mail from the mailbox
maybe you cold help me
Hi Ruben,

Kindly go to Admin --> Mail Server Settings and if the protocol selected is POP or IMAP, change it POPS or IMAPS and save the changes. While saving if you get the error again asking to install Trusted or Self Signed Certificate, then please go ahead and follow the steps present in the below troubleshooting link,

While following the steps, enter the port number as 993 or 995 as according to the one which you are using and generate the certificate.

SDP Support - FAQ
ServiceDesk Plus - Help Desk Software of your Choice