ManageEngine Forums

MDB Pool Counts

in AppManager  •  Troubleshooting  •  19 May 2011
AppManager not displying Pool size count for MDB's under EJB details. Any thing missing ?
This is for Websphere 6.1

Replies (22)

Paul Jacob Employee
Hi,
 
Are you seeing data for all other attributes? Please send in following details to appmanager-support@manageengine.com
 
1.)Complete screen-shot of the monitor details page of the WAS. Send in multiple screen-shots to show all the details.
 
2.)Send in the perfservlet data in xml format. Access it over browser using the appropriate URL as illustrated in below link:
 
 
Thanks & Regards,
Paul Jacob
yes, I am seeing data for Total Method calls and Avg Method Resp only.
 
This is the sample from perfservlet
 
 <Stat name="TransactionMDB">
  <Stat name="Methods" />
  <CountStatistic ID="1" count="0" lastSampleTime="1303351858980" name="CreateCount" startTime="1303351858980" unit="N/A" />
  <CountStatistic ID="2" count="0" lastSampleTime="1303351858980" name="RemoveCount" startTime="1303351858980" unit="N/A" />
  <CountStatistic ID="11" count="164868" lastSampleTime="1305905085917" name="MethodCallCount" startTime="1303351858980" unit="N/A" />
  <TimeStatistic ID="12" lastSampleTime="1305905085999" max="9408" min="41" name="MethodResponseTime" startTime="1303351858980" totalTime="131895520" unit="MILLISECOND" />
  <RangeStatistic ID="25" highWaterMark="20" integral="5.0944692683E10" lastSampleTime="1305905807841" lowWaterMark="0" mean="19.947420819950395" name="PooledCount" startTime="1303351858980" unit="N/A" value="20" />
  <CountStatistic ID="26" count="164838" lastSampleTime="1305905085917" name="MessageCount" startTime="1303351858980" unit="N/A" />
  </Stat>
Paul Jacob Employee
Hi,
 
 Please send in following details to appmanager-support@manageengine.com
 
1.)Complete screen-shot of the monitor details page of the WAS. Send in multiple screen-shots to show all the details currently getting displayed on the screen.
 
2.)Send in the complete perfservlet data as an xml file. Access it over browser using the appropriate URL as illustrated in below link:
 
 
We can analyze the issue and assist further.
 
Thanks & Regards,
Paul Jacob
Attached SS from console.

Attachments

Attached perf data

Attachments

Paul Jacob Employee
Hi,
 
Thank you for the details. Please allow some time. We can analyze this and get back to you as soon as possible.
 
Thanks & Regards,
Paul Jacob
i am using professional editon, will there be any difference between professional and enterprise edition ?


Paul Jacob Employee
Hi,
 
Enterprise Edition mainly offers sclability when you have large number of monitors. Professional Edition will support only a maximum of 250 - 300 monitors. If your monitoring requiremnt is around 500 monitors you can opt for Enterprise Edition. Feature wise both are same except for Enterprise Edition offers failover support. Please find the comparison document from below link:
 
 
Thanks & Regards,
Paul Jacob
Thanks for the update, please update about missing pool count. 
i am waiting on that.
any update on this issue, why i am not seeing pool counts for ejb.
Paul Jacob Employee
Hi,
 
We are currently working on EJB Pool size issue. We checked the perfservlet and it seems like data is present for all counters. We need to identify where the exception is occuring. Please send us the latest support files.
 
Go to Admin Tab-->Logging-->Set it to print all logs and save.(You may revert this to default setting after sending the logs)
 
Stop Applications Manager.
 
Rename the logs folder under ..\Appmanager9\ folder to logs_old.
 
Start Applications Manager.
 
Make sure the WAS monitor is polling at 5 minutes interval. Run it for 30 minutes and then create a support information file and send it to us. Please find the steps to send support files from below link:
 
 
Note : If you are doing FTP then after connecting to FTP move to the ../pub/ folder and place the file there. Send in the file name to appmanager-support@manageengine.com
 
Thanks & Regards,
Paul Jacob
Paul Jacob Employee
Hi,
 
We tested your perfservlet data further. We tried simulating your environment from the perfservlet data and created your monitor here. However the screen-shots you have attached in this forum do not match with any nodes obtained from the perfservlet data after simulating your environment in Applications Manager.(Please see the attached image)
 
1.)Have you sent us the perfservelt data for the same WAS monitor that you have illustrated in the screeen-shots? Please check and confirm this.
 
2.)Send in the correct perfservelt data in xml format and the complete screen-shots of the node where you notice the pool size missing for the EJBs.(Monitor information section was missing in previous screen-shots and we had to go through each node trying to match the the EJB details.)
 
3.)Also create a support file and send it to us as mentioned in the previous email.
 
Note: It is recomended to send the requested information to appmanager-support@manageengine.com and we can raise a ticket and work with you to identify and resolve any issues.
 
Thanks & Regards,
Paul Jacob

Attachments

Paul Jacob Employee
Hi,
 
In WAS monitor do not edit/change the default display names picked up when adding the monitor. If you have edited/changed display names that could create issues. You may have to then delete and re-create the monitors.
 
Thanks & Regards,
Paul Jacob
I did not tried changing any display names.

Attached screenshot for the below ejb

Here is the perfservlet output:

<Stat name="TransactionMDB">
  <Stat name="Methods" />
  <CountStatistic ID="1" count="0" lastSampleTime="1306241586282" name="CreateCount" startTime="1306241586282" unit="N/A" />
  <CountStatistic ID="2" count="0" lastSampleTime="1306241586282" name="RemoveCount" startTime="1306241586282" unit="N/A" />
  <CountStatistic ID="11" count="43" lastSampleTime="1306942318238" name="MethodCallCount" startTime="1306241586282" unit="N/A" />
  <TimeStatistic ID="12" lastSampleTime="1306942318330" max="642" min="20" name="MethodResponseTime" startTime="1306241586282" totalTime="6106" unit="MILLISECOND" />
  <RangeStatistic ID="25" highWaterMark="1" integral="6.74118867E8" lastSampleTime="1306943065383" lowWaterMark="0" mean="0.9609963661625893" name="PooledCount" startTime="1306241586282" unit="N/A" value="1" />


Attachments

Paul Jacob Employee
Hi,
 
Thank you for the reply. However could you also upload the complete perfservelt data in xml format. We need to load this perfservlet in Applications Manager to trace the issue.
 
Also include the screen-shot of Monitor information section of the node for which you have uploaded the screen-shot in the previous post.
 
Thanks & Regards,
Paul Jacob
Attached perf output

Attachments

got chance to go thorough the perfservlet output ?
Paul Jacob Employee
Hi,
 
Apologize for the delay. We are currently working on this issue. If posible include the screen-shot of Monitor information section of the node for which you have uploaded the screen-shot in the previous post.(poolCount_1.JPG on 01-Jun-2011)
 
Thanks & Regards,
Paul Jacob
any updates ?
Paul Jacob Employee
Hi,
 
We are unable to isolate the issue as we are not sure which node you are refering to and on which server you are expecting the Poolsize to show up. I discussed with the developer and he requested to Include the screen-shot of Monitor information section of the node for which you have uploaded the screen-shot in the previous post.(poolCount_1.JPG on 01-Jun-2011)
 
Kindly be specific with the complete screen-shot of the node (Showing monitor information section and EJB details) where you expect the poolsize to be present and we can check it in the perfservlet data.
 
Note: For faster resolution you can contact support at appmanager-support@manageengine.com with the above requested information. Also if possible we can take a look over remote support session and assist further. Let me know your convenient time with timezone.
 
Thanks & Regards,
Paul Jacob
Let me know when do you want to have remote session, I am Central Time zone.
Paul Jacob Employee
Hi,
 
Send in an email to appmanager-support@manageengine.com  with reference to this forum post. I can then check with the developer and schedule the session early next week. Include your direct phone number. we can email you the invite for the meeting.
 
Thanks & Regards,
Paul Jacob