ManageEngine Forums
Hello

We are running AD Self service on a dedicated Windows 2008 R2, Exchange 2010 server.
ADSelf service is Product Version: 4.5 Build no: 4500

Random users are experiencing the follwing error when attempting to log into the portal with the correct username/passwords

"Permission Denied. Kindly contact your Administrator"

I looked through the list of fixes in version 4544 and fix 2 below seems to be addressing my issues.

====================================================================
Version 4.5 Build 4544: (10/July/2012)
Fixed:
  • Overwriting of virtual IP Configuration Issue.
  • Rare occurrence of a 'Denied Access to Self Service Portal' for random user(s).
  • Service Pack Updation issue.
The OU's are correct in the policy configuration, all users are within managed OU of ADSelfService.

====================================================================

This post is more for verification and to identify if there are any other steps I can take before implementing the service pack. Could you please advise?

Replies (5)

Hi,

The user's are denied access to the application. Please follow the steps below to allow users from specific OUs to access ADSelfService Plus:

* Click "Configuration" tab --> Self-Service --> Policy Configuration.
* Click "Select OUs" button, allow access to the application by enabling OUs and click "OK" button.

Regards

ADSelfService Plus Team
Direct Tel : +1-408-916-9890
Self Service Password Management Solution 
Hello Raghuraman

Thankyou for your response.

The OU that the user is in is enabled and selected within the "Select OU's windows".
This error occurs for random users. Most users can log in successfully however a small amount experience the error "Permission Denied. Kindly contact your Administrator". They are all in the same OU in Active Directory.

Do you have any other suggestions?

Kind regards
Mike Gould
Hi Mike,

Please update the credential provided under the "Domain Settings" (when the software is running as an application) page and then try to login. Follow the steps provided below to update the username/password.

* Click “Domain Settings” link on the top right-hand side corner.
* Click “Edit Domain Details” icon under “Actions” column.
* Enable “Authentication” check box, configure/update “Domain Username” and “Domain Password”.

Note: The “Domain Username” and “Domain Password” must be of the user belonging to “Domain Admins” or "Enterprise Admins" group. When running as service, please add service account on the "LogOn" tab under the service properties.

Further, please follow the steps to remove the users from restricted users list (if any).

* Click "Admin" tab --> License Management --> Restrict Users.
* Choose the users and click "Allow Access" button.

Regards,  

ADSelfService Plus Team. 
Direct Tel : +1-408-916-9890.
Self Service Password Management Solution
Hi Raghuraman

I have reapplied the password as well as ensure that all deleted/disabled/inactive users are not being applied to the licence count.

The error is still being received for random users.

Kind regards
Mike Gould
Hi,

Please send an email to our support team at "support@adselfserviceplus.com" along with your contact details, so that we can call and assist you.

Regards,  

Mike
ADSelfService Plus Team. 
Direct Tel : +1-408-916-9890.
Self Service Password Management Solution