theweblord2000 Formation Lap
Hi 

I am trying to set up the iPhone/iPad app to work with our SD+ which is hosted on our LAN.

I have an external Internet IP which I have assigned a domain name to.

ServiceDesk Plus is configured to use SSL and certificate is install and can be verified when connected on the LAN

On our firewall we have configured NAT to direct https requests from the Internet IP to our local LAN IP

I have configured the correct domain name using SSL on the iPhone app

I followed the guide in scenario 1 here

All I get is "The request timed out", and occasionally "An SSL error has occurred and a secure connection to the server cannot be made"

Is there anything else I can try?

Thanks




Replies (5)

Hi,

Please try entering the IP address of the ServiceDesk Plus server in the mobile app server settings page instead of the domain name. Also check whether you can able to connect the same via mobile browser.

Thanks & regards,
Rajdurai
ME Mobile
theweblord2000 Formation Lap

On internal wifi I got the option for Local Account or ShowAllDomains to appear, neither would let me log in, we used AD authentication on our workstations.

Still no response from external internet though

Hi,

For AD authentication, in order to choose domain while login through the app, enable "Allow domain filtering during login" under Admin > Self service portal settings in the product. Type in the username correctly in the app so that matching domains get listed in the domain field. Now you can able to login into the app by selecting the domain name.

Thanks & regards,
Rajdurai
ME Mobile
Demetrius 35 Laps
Hi Rajdurai,

In our environment, we had to disable the option "Allow domain filtering during login", based on a recommendation from our IT Security department. We will not turn this option back on because the APP needs it. As a temporary work-around, we are using local authentication when using the APP, until a fix is available. I was told that this fix would be released by the end of this month. Can you please confirm? The corresponding issue ID is SD-65516.

Best regards,
Demetrius
theweblord2000 Formation Lap

Thanks rajdurai.rs

Enabling the "Allow Domain Filtering" worked a charm


Thanks again